Getting error while testing app in sandbox on Edgegallery verison 1.5.1


Kumar Prasad, Vikash
 

Dear Team,

I am trying to follow the same steps to deploy/develop app on edgegallery as I used to do on version 1.3.0, but while doing sandbox test

I am getting below error, can anybody guide me here how to resolve this problem.

 

Exception happens when export image: [org.edgegallery.developer.service.application.action.impl.container.InstantiateContainerAppAction.queryPodStatus(InstantiateContainerAppAction.java:181), org.edgegallery.developer.service.application.action.impl.container.InstantiateContainerAppAction.queryInstantiateStatus(InstantiateContainerAppAction.java:160), org.edgegallery.developer.service.application.action.impl.InstantiateAppAction.execute(InstantiateAppAction.java:95), org.edgegallery.developer.service.application.impl.container.ContainerAppOperationServiceImpl$InstantiateContainerAppProcessor.run(ContainerAppOperationServiceImpl.java:295)]

pod Information :

Refresh

 

I was just curious to know whether anything extra step I have to perform in version 1.5.1 which we didn’t have to perform in version 1.3.0

 

Thanks

Vikash kumar prasad

 

 


Kumar Prasad, Vikash
 

Dear liyuanyuan,

When I am trying to deploy my app in sandbox environment I have given namespace in my yaml file, but when I am checking

On my terminal using #kubectl get pods -A, I can see my app is running on pod but in default namespace, while I have specified

Namespace in my yaml file as below

 

namespace: '{{ .Values.appconfig.appnamespace }}'

 

I think it is failing in this step only?

 

Thanks

Vikash kumar prasad

 

From: Jasmine-lyy@... <Jasmine-lyy@...>
Sent: Monday, February 28, 2022 12:25 PM
To: Kumar Prasad, Vikash (ADV D AA DASS T&I TPOCS) <vikash.kumarprasad@...>
Subject: Re: [EdgeGallery] Getting error while testing app in sandbox on Edgegallery verison 1.5.1

 

Hi Vikash,

The error log you provided is not enough, and it is impossible to judge what the problem is at present.

Can you provide more detailed operation steps and error log so that we can locate the error.

 

Thanks

liyuanyuan


 

Date: 2022-02-28 13:37

Subject: [EdgeGallery] Getting error while testing app in sandbox on Edgegallery verison 1.5.1

Dear Team,

I am trying to follow the same steps to deploy/develop app on edgegallery as I used to do on version 1.3.0, but while doing sandbox test

I am getting below error, can anybody guide me here how to resolve this problem.

 

Exception happens when export image: [org.edgegallery.developer.service.application.action.impl.container.InstantiateContainerAppAction.queryPodStatus(InstantiateContainerAppAction.java:181), org.edgegallery.developer.service.application.action.impl.container.InstantiateContainerAppAction.queryInstantiateStatus(InstantiateContainerAppAction.java:160), org.edgegallery.developer.service.application.action.impl.InstantiateAppAction.execute(InstantiateAppAction.java:95), org.edgegallery.developer.service.application.impl.container.ContainerAppOperationServiceImpl$InstantiateContainerAppProcessor.run(ContainerAppOperationServiceImpl.java:295)]

pod Information :

Refresh

 

I was just curious to know whether anything extra step I have to perform in version 1.5.1 which we didn’t have to perform in version 1.3.0

 

Thanks

Vikash kumar prasad

 

 


Kumar Prasad, Vikash
 

Dear liyuanyuan,

Attached is mine yaml file.

Thanks

Vikash kumar prasad

 

 

From: Jasmine-lyy@... <Jasmine-lyy@...>
Sent: Monday, February 28, 2022 2:00 PM
To: Kumar Prasad, Vikash (ADV D AA DASS T&I TPOCS) <vikash.kumarprasad@...>
Subject: Re: RE: [EdgeGallery] Getting error while testing app in sandbox on Edgegallery verison 1.5.1

 

Hi Vikash,

Can you send me your yaml, I will deploy it in my environment.

 

Thanks

liyuanyuan


 

Date: 2022-02-28 16:00

Subject: RE: [EdgeGallery] Getting error while testing app in sandbox on Edgegallery verison 1.5.1

Dear liyuanyuan,

When I am trying to deploy my app in sandbox environment I have given namespace in my yaml file, but when I am checking

On my terminal using #kubectl get pods -A, I can see my app is running on pod but in default namespace, while I have specified

Namespace in my yaml file as below

 

namespace: '{{ .Values.appconfig.appnamespace }}'

 

I think it is failing in this step only?

 

Thanks

Vikash kumar prasad

 

From: Jasmine-lyy@... <Jasmine-lyy@...>
Sent: Monday, February 28, 2022 12:25 PM
To: Kumar Prasad, Vikash (ADV D AA DASS T&I TPOCS) <
vikash.kumarprasad@...>
Subject: Re: [EdgeGallery] Getting error while testing app in sandbox on Edgegallery verison 1.5.1

 

Hi Vikash,

The error log you provided is not enough, and it is impossible to judge what the problem is at present.

Can you provide more detailed operation steps and error log so that we can locate the error.

 

Thanks

liyuanyuan


 

Date: 2022-02-28 13:37

Subject: [EdgeGallery] Getting error while testing app in sandbox on Edgegallery verison 1.5.1

Dear Team,

I am trying to follow the same steps to deploy/develop app on edgegallery as I used to do on version 1.3.0, but while doing sandbox test

I am getting below error, can anybody guide me here how to resolve this problem.

 

Exception happens when export image: [org.edgegallery.developer.service.application.action.impl.container.InstantiateContainerAppAction.queryPodStatus(InstantiateContainerAppAction.java:181), org.edgegallery.developer.service.application.action.impl.container.InstantiateContainerAppAction.queryInstantiateStatus(InstantiateContainerAppAction.java:160), org.edgegallery.developer.service.application.action.impl.InstantiateAppAction.execute(InstantiateAppAction.java:95), org.edgegallery.developer.service.application.impl.container.ContainerAppOperationServiceImpl$InstantiateContainerAppProcessor.run(ContainerAppOperationServiceImpl.java:295)]

pod Information :

Refresh

 

I was just curious to know whether anything extra step I have to perform in version 1.5.1 which we didn’t have to perform in version 1.3.0

 

Thanks

Vikash kumar prasad

 

 


Kumar Prasad, Vikash
 

Dear liyuanyuan,

Sorry for late reply, I was on leave on 1st march so couldn’t reply.

Thanks for clarifying the things, that was just an assumption that because we are not providing the correct namespace because of that

I am getting below error,

 

Exception happens when export image: [org.edgegallery.developer.service.application.action.impl.container.InstantiateContainerAppAction.queryPodStatus(InstantiateContainerAppAction.java:181), org.edgegallery.developer.service.application.action.impl.container.InstantiateContainerAppAction.queryInstantiateStatus(InstantiateContainerAppAction.java:160), org.edgegallery.developer.service.application.action.impl.InstantiateAppAction.execute(InstantiateAppAction.java:95), org.edgegallery.developer.service.application.impl.container.ContainerAppOperationServiceImpl$InstantiateContainerAppProcessor.run(ContainerAppOperationServiceImpl.java:295)]

pod Information :

Refresh

 

 

So still question remains why I am getting the above error in sandbox test? How do I check the log? Where will I get the log file?

 

Thanks

Vikash kumar prasad

 

From: Jasmine-lyy@... <Jasmine-lyy@...>
Sent: Tuesday, March 1, 2022 7:04 AM
To: Kumar Prasad, Vikash (ADV D AA DASS T&I TPOCS) <vikash.kumarprasad@...>
Subject: Re: RE: [EdgeGallery] Getting error while testing app in sandbox on Edgegallery verison 1.5.1

 

Hi Vikash,

If the parameter configuration method is used in yaml to obtain the namespace (such as namespace1.png), the corresponding namespace will be obtained from value.yaml during deployment(such as namespace2.png) , 

and the namespace value in value.yaml is default, then What you find with the kubectl command is default.

 

Thanks

liyuanyuan


 

Date: 2022-02-28 17:14

Subject: RE: RE: [EdgeGallery] Getting error while testing app in sandbox on Edgegallery verison 1.5.1

Dear liyuanyuan,

Attached is mine yaml file.

Thanks

Vikash kumar prasad

 

 

From: Jasmine-lyy@... <Jasmine-lyy@...>
Sent: Monday, February 28, 2022 2:00 PM
To: Kumar Prasad, Vikash (ADV D AA DASS T&I TPOCS) <vikash.kumarprasad@...>
Subject: Re: RE: [EdgeGallery] Getting error while testing app in sandbox on Edgegallery verison 1.5.1

 

Hi Vikash,

Can you send me your yaml, I will deploy it in my environment.

 

Thanks

liyuanyuan


 

Date: 2022-02-28 16:00

Subject: RE: [EdgeGallery] Getting error while testing app in sandbox on Edgegallery verison 1.5.1

Dear liyuanyuan,

When I am trying to deploy my app in sandbox environment I have given namespace in my yaml file, but when I am checking

On my terminal using #kubectl get pods -A, I can see my app is running on pod but in default namespace, while I have specified

Namespace in my yaml file as below

 

namespace: '{{ .Values.appconfig.appnamespace }}'

 

I think it is failing in this step only?

 

Thanks

Vikash kumar prasad

 

From: Jasmine-lyy@... <Jasmine-lyy@...>
Sent: Monday, February 28, 2022 12:25 PM
To: Kumar Prasad, Vikash (ADV D AA DASS T&I TPOCS) <vikash.kumarprasad@...>
Subject: Re: [EdgeGallery] Getting error while testing app in sandbox on Edgegallery verison 1.5.1

 

Hi Vikash,

The error log you provided is not enough, and it is impossible to judge what the problem is at present.

Can you provide more detailed operation steps and error log so that we can locate the error.

 

Thanks

liyuanyuan


 

Date: 2022-02-28 13:37

Subject: [EdgeGallery] Getting error while testing app in sandbox on Edgegallery verison 1.5.1

Dear Team,

I am trying to follow the same steps to deploy/develop app on edgegallery as I used to do on version 1.3.0, but while doing sandbox test

I am getting below error, can anybody guide me here how to resolve this problem.

 

Exception happens when export image: [org.edgegallery.developer.service.application.action.impl.container.InstantiateContainerAppAction.queryPodStatus(InstantiateContainerAppAction.java:181), org.edgegallery.developer.service.application.action.impl.container.InstantiateContainerAppAction.queryInstantiateStatus(InstantiateContainerAppAction.java:160), org.edgegallery.developer.service.application.action.impl.InstantiateAppAction.execute(InstantiateAppAction.java:95), org.edgegallery.developer.service.application.impl.container.ContainerAppOperationServiceImpl$InstantiateContainerAppProcessor.run(ContainerAppOperationServiceImpl.java:295)]

pod Information :

Refresh

 

I was just curious to know whether anything extra step I have to perform in version 1.5.1 which we didn’t have to perform in version 1.3.0

 

Thanks

Vikash kumar prasad