Edgegallery 1.5 giving error while installing


Kumar Prasad, Vikash
 

Dear team,

I am installing Edgegallery 1.5 on my Debian OS 10 but while installing it is giving below error.

 

 

Thanks

Vikash kumar prasad


Mansuroglu, Zekeriya
 

Hi,

 

I had the same problem. I could resolve it by changing the gid from 1000 to 999. Of course the gid 999 should be unused in the system. The file to be edited is roles/init/tasks/init_offline.yml.

See attachment.

Regards

Zekeriya

 

Von: main@edgegallery.groups.io <main@edgegallery.groups.io> Im Auftrag von Kumar Prasad, Vikash
Gesendet: Freitag, 28. Januar 2022 12:26
An: main@edgegallery.groups.io
Betreff: [EdgeGallery] Edgegallery 1.5 giving error while installing

 

Dear team,

I am installing Edgegallery 1.5 on my Debian OS 10 but while installing it is giving below error.

 

 

Thanks

Vikash kumar prasad


Kumar Prasad, Vikash
 

Dear Zekeriya,

Thanks for your reply , I have now another error as below. I am trying to install Edgegallery on Debian 10

 

 

Can anyone suggest me how to resolve it?

Thanks

Vikash kumar prasad

 

 

From: main@edgegallery.groups.io <main@edgegallery.groups.io> On Behalf Of Mansuroglu, Zekeriya via groups.io
Sent: Friday, January 28, 2022 5:03 PM
To: main@edgegallery.groups.io
Subject: Re: [EdgeGallery] Edgegallery 1.5 giving error while installing

 

Hi,

 

I had the same problem. I could resolve it by changing the gid from 1000 to 999. Of course the gid 999 should be unused in the system. The file to be edited is roles/init/tasks/init_offline.yml.

See attachment.

Regards

Zekeriya

 

Von: main@edgegallery.groups.io <main@edgegallery.groups.io> Im Auftrag von Kumar Prasad, Vikash
Gesendet: Freitag, 28. Januar 2022 12:26
An: main@edgegallery.groups.io
Betreff: [EdgeGallery] Edgegallery 1.5 giving error while installing

 

Dear team,

I am installing Edgegallery 1.5 on my Debian OS 10 but while installing it is giving below error.

 

 

Thanks

Vikash kumar prasad


Mansuroglu, Zekeriya
 

In the offline installation instructions of EdgeGallery it is recommended to use Ubuntu 18.04.

I’m not sure if the installation works on Debian 10 at all.

 

My experience is that you should uninstall EdgeGallery after an aborted install before reinstall it.

 

Von: main@edgegallery.groups.io <main@edgegallery.groups.io> Im Auftrag von Kumar Prasad, Vikash
Gesendet: Freitag, 28. Januar 2022 13:16
An: main@edgegallery.groups.io
Betreff: Re: [EdgeGallery] Edgegallery 1.5 giving error while installing

 

Dear Zekeriya,

Thanks for your reply , I have now another error as below. I am trying to install Edgegallery on Debian 10

 

 

Can anyone suggest me how to resolve it?

Thanks

Vikash kumar prasad

 

 

From: main@edgegallery.groups.io <main@edgegallery.groups.io> On Behalf Of Mansuroglu, Zekeriya via groups.io
Sent: Friday, January 28, 2022 5:03 PM
To: main@edgegallery.groups.io
Subject: Re: [EdgeGallery] Edgegallery 1.5 giving error while installing

 

Hi,

 

I had the same problem. I could resolve it by changing the gid from 1000 to 999. Of course the gid 999 should be unused in the system. The file to be edited is roles/init/tasks/init_offline.yml.

See attachment.

Regards

Zekeriya

 

Von: main@edgegallery.groups.io <main@edgegallery.groups.io> Im Auftrag von Kumar Prasad, Vikash
Gesendet: Freitag, 28. Januar 2022 12:26
An: main@edgegallery.groups.io
Betreff: [EdgeGallery] Edgegallery 1.5 giving error while installing

 

Dear team,

I am installing Edgegallery 1.5 on my Debian OS 10 but while installing it is giving below error.

 

 

Thanks

Vikash kumar prasad


xudan
 

Hi Zekeriya and Vikash,

 

For the first problem, GID 1000 already exists, the solution you have done cannot solve the problem even though the Ansible tasks got success.

The GID of docker group in some EdgeGallery Docker images is 1000 which will raise the inconsistency with the 999 you edited.

Then some services of EdgeGallery will got permission deny when trying to access docker images in containers with different docker GIDs 999 (in hosts) and 1000 (in containers).

 

There are 2 solutions for this problem:

1. Find out which group already exists in your hosts (including master and worker nodes) with GID 1000, and change the ID of them to free GID 1000 for docker group.

2. Use our v1.5.1 version which is released yesterday. In this version, the docker GID has been changed to be 1166 in both the Ansible scripts and all Related EdgeGallery images. This GID 1166 should be with low probability of being occupied.

 

For the second problem, failed to install NFS. I haven’t tried to install in Debian 10 and haven’t met this error before, so could not give you any solution now.

From the log, it seems to be that the deb packages of NFS EdgeGallery provides are not work for Debian 10.

You can switch to Ubuntu 18.04 to do this installation. Also I will try with Debian 10 to reproduce this issue.

 

BR,

Dan Xu

 

发件人: main@edgegallery.groups.io [mailto:main@edgegallery.groups.io] 代表 Mansuroglu, Zekeriya
发送时间: 2022128 20:25
收件人: main@edgegallery.groups.io
主题: Re: [EdgeGallery] Edgegallery 1.5 giving error while installing

 

In the offline installation instructions of EdgeGallery it is recommended to use Ubuntu 18.04.

I’m not sure if the installation works on Debian 10 at all.

 

My experience is that you should uninstall EdgeGallery after an aborted install before reinstall it.

 

Von: main@edgegallery.groups.io <main@edgegallery.groups.io> Im Auftrag von Kumar Prasad, Vikash
Gesendet: Freitag, 28. Januar 2022 13:16
An: main@edgegallery.groups.io
Betreff: Re: [EdgeGallery] Edgegallery 1.5 giving error while installing

 

Dear Zekeriya,

Thanks for your reply , I have now another error as below. I am trying to install Edgegallery on Debian 10

 

 

Can anyone suggest me how to resolve it?

Thanks

Vikash kumar prasad

 

 

From: main@edgegallery.groups.io <main@edgegallery.groups.io> On Behalf Of Mansuroglu, Zekeriya via groups.io
Sent: Friday, January 28, 2022 5:03 PM
To: main@edgegallery.groups.io
Subject: Re: [EdgeGallery] Edgegallery 1.5 giving error while installing

 

Hi,

 

I had the same problem. I could resolve it by changing the gid from 1000 to 999. Of course the gid 999 should be unused in the system. The file to be edited is roles/init/tasks/init_offline.yml.

See attachment.

Regards

Zekeriya

 

Von: main@edgegallery.groups.io <main@edgegallery.groups.io> Im Auftrag von Kumar Prasad, Vikash
Gesendet: Freitag, 28. Januar 2022 12:26
An: main@edgegallery.groups.io
Betreff: [EdgeGallery] Edgegallery 1.5 giving error while installing

 

Dear team,

I am installing Edgegallery 1.5 on my Debian OS 10 but while installing it is giving below error.

 

 

Thanks

Vikash kumar prasad